Mantenimiento en compras
Incident Report for Fondeadora
Resolved
This incident has been resolved.
Posted May 31, 2023 - 08:53 CDT
Investigating
We are currently investigating this issue.
Posted May 31, 2023 - 07:06 CDT
This incident affected: 💳 Compras con tarjeta.